Port-prep archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: 7.1 on a IBM 43P, 7248-132


I know this is quite some time later, but I'd be very interested in your
kernel config!!


On 07/22/17 02:55, T wrote:
> Finally got this to work:
> http://dmesgd.nycbug.org/index.cgi?do=view&id=3228
> I had to recompile the kernel to add in support for a PCI NIC and PCI
> USB card and took the opportunity to trim out some things that were not
> needed or planned on being used (WD).
> I was wrong about the 2MB limit but ended up making a small kernel to
> put into the PReP partion based on the INSTALL_SMALL kernel config.
> I can post the kernel config files if you would find it useful.
> On 07/01/2017 01:34 AM, T wrote:
>> I'm using the integrated ncr53c810 SCSI-2 controller so it may not be
>> the same issue you are having.
>> Using sysinst_small.fs in the PReP partition allowed loading of the
>> boot loader. The boot process will proceed to a point where it
>> requires user input to specify a boot device because it does not find
>> one by default. Providing it "sd0" will allow for the generic kernel
>> to load (when going multi-user?) and provide the login prompt.
>> If I enter "boot -s" at the boot loader prompt (single user), it will
>> boot into sysinst.
>> sysinst.fs will boot when I network boot with BOOTP/TFTP. I have not
>> tried writing that into the PReP partition (as I did with the small
>> version) but I suspect it would work because it is less than 2MB in size.
>> sysinst_com0.fs used in the same way mentioned above will not work for
>> me. I have not tried sysinst_small_com0.fs in this manner.
>> On 06/30/2017 03:35 AM, Artyom Tarasenko wrote:
>>> Interesting. At a first glance the log says that the scsi driver is
>>> broken in the NetBSD 7+. I hit that problem in this thread:
>>> http://mail-index.netbsd.org/port-prep/2017/01/23/msg000108.html
>>> Are you saying the very same NetBSD version works for you if you use a
>>> smaller sysinit image?
>>> On Fri, Jun 30, 2017 at 7:23 AM, T <bobs%thelibertytree.org@localhost> wrote:
>>>> The PReP partition was set to use 5MB (as recommended in the
>>>> documentation)
>>>> and located in the first BIOS partition. Only the kernels 2MB or
>>>> less seem
>>>> to make it to the boot loader for me. The <2MB serial console
>>>> sysinit image
>>>> will make it to the boot loader if I put it into the PReP partition,
>>>> but
>>>> will not boot past that point as mentioned in this thread:
>>>> http://mail-index.netbsd.org/port-prep/2017/06/27/msg000119.html
>>>> On 06/29/2017 03:32 AM, Artyom Tarasenko wrote:
>>>>> Is it a general issue, or was the PReP partition just too small in
>>>>> your
>>>>> setup?
>>>>> On Thu, Jun 29, 2017 at 10:15 AM, T <bobs%thelibertytree.org@localhost> wrote:
>>>>>> Found that the kernel size is the issue by using mkbootimage with
>>>>>> install_small.fs and dding that into the PreP partition and
>>>>>> getting that
>>>>>> to
>>>>>> boot. Will end up doing the small kernel work around mentioned in the
>>>>>> referenced email thread.
>>>>>> On 06/24/2017 06:37 PM, t wrote:
>>>>>>> Hello,
>>>>>>> I'm trying to get NetBSD 7.1 working on a 7248-132 but cannot get
>>>>>>> the
>>>>>>> computer to boot from the SCSI disk after installation. Booting the
>>>>>>> install kernel over the network seems to work with BOOTP/TFTP. After
>>>>>>> completing the installation process and restarting the machine, I
>>>>>>> load
>>>>>>> into the SMS and change the boot priority to boot from the SCSI disk
>>>>>>> instead of the network. Upon restarting and completing the boot
>>>>>>> screen,
>>>>>>> the computer ends up at a black screen and blinking cursor.
>>>>>>> I believe this issue may be related to this thread:
>>>>>>> https://mail-index.netbsd.org/port-prep/2014/07/thread1.html#000101
>>>>>>> This is my first time installing NetBSD so it could also be
>>>>>>> something
>>>>>>> I'm
>>>>>>> doing.
>>>>>>> I've tried re-writing the generic kernel to the prep partition with
>>>>>>> "mkbootimage" but that did not seem to work.
>>>>>>> Any help would be appreciated.
>>>>>>> One other thing I've noticed with this machine is interactions
>>>>>>> with the
>>>>>>> pcn0 device seem to occasionally lockup the machine. I originally
>>>>>>> was
>>>>>>> going to install the NetBSD binary packages from a NFS mount, but
>>>>>>> the
>>>>>>> system would lockup halfway through the installation of the second
>>>>>>> package. I bypassed this issue by using the CDROM instead.

Home | Main Index | Thread Index | Old Index