Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: questions and report on setting up UMAX Apus 2000 boxes


I dig out my Apus2000/200, and it still works.

> 1) How come I am (sometimes... if I don't get a DEFAULT CATCH) able to 
> boot scsi/sd@3:0 while I cannot see that device in the device list?

It looks Apus2000's OpenFirmware doesn't probe CD-ROM drives
at boot time. Probably it doesn't reset CD-ROM drives or scsibus
properly so we have to reset twice to boot from the CD-ROM.

> 2) Most of my Apus boxes have a dead nvram battery, I need to reenter 
> the special settings at each poweron or power cable plug.  The 
> nvram/battery is a RAYONAC Computer Clock Battery 840 4.5 Volts 
> ALKALINE.  Are there any successful reports on building a custom battery 
> with standard Alkaline batteries, or are these batteries still available 
>   some place?  The nvram/battery is some kind of a little monster, but 
> the PINs are pretty standard, just like PC Speaker PINs.

No idea, but I wonder if it's rechargable.

> 3) Is cmd-alt-n-v supposed to work?  This is the right command to 
> initialize the nvram, even further than a set-defaults would do, right? 
>   What about cmd-alt-p-r I've seen somewhere, what does it do?

cmd-alt-p-r will work to initialize NVRAM variables,
but if some important variables (like real-base etc) have
fatal wrong values, cmd-alt-p-r didn't help.
(I had to remove a battery whole a day to reset them)

> 4-5) Some of those boxes I have don't work correctly.  Beside the damn 
> DEFAULT CATCH issue I am talking about in the next part of this message, 
> I've got:
> - jason which has no network interface
> - musset which always gets a kernel trap
> - salomon which has no network interface
> - worst of all, lucrece that didn't even get the GONG sound at power-on. 
>   We cleaned-it up here at the lab and it finally GONGs again but 
> NOTHING SHOWS UP on the serial console... Such a pitty!

At least 3c905B (ex(4) on NetBSD) and SMC83C170 (epic(4)) work
on my Apus2000.

> I should clean the PCI slots with F2 spray and/or change the network 
> cards for those with the network issue.

Yes, Apus2000's PCI slots are a bit fragile, and it will
really help to cleanup contacts of boards and slots.

> For the kernel trap, I don't really know what to do with it.  I doubt it 
> is a netbsd bug since I've got no such troubles on the six other machines,
> ex0 at pci0 dev 14 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x30)
> ex0: interrupting at irq 25
> trap: pid 0.1 (system): kernel MCHK trap @ 0x101570 (SRR1=0x41030)
> panic: trap
> I can only guess it's a hardware issue -- any idea what I should look 
> into on the musset box?
> Finally about the lucrece box which doesn't show anything on the 
> console, any hints on how to deal with it?

Incomplete electrical contacts (bad data bus, address bus, interrupts
lines etc.) could cause kernel traps or silent hang before boot.

Here is a log of 6.1 INSTALL CD on my Apus2000/200:

Open Firmware, 2.0
To continue booting the MacOS type:
To continue booting from the default boot device type:
0 > boot scsi/sd@3:0 DEFAULT CATCH!, code=FFF00300 at   %SRR0: FF80AC9C   
%SRR1: 0000B070 
[ ctrl+cmd+power to restart ]

Open Firmware, 2.0
To continue booting the MacOS type:
To continue booting from the default boot device type:
0 > boot scsi/sd@3:0
OF_open bootpath=scsi/sd@3
read stage 2 blocks: 0. done!
starting stage 2...

>> NetBSD/macppc OpenFirmware Boot, Revision 1.12
open /netbsd: Device not configured
open /netbsd.gz: Device not configured
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009, 2010, 2011, 2012
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

total memory = 65536 KB
avail memory = 57460 KB
found ohare PIC at f3000000
bootpath: scsi/sd@3/netbsd.macppc
mainbus0 (root)
cpu0 at mainbus0: 603ev (Revision 2.1), ID 0 (primary)
cpu0: HID0 0x90c001<DOZE,DPM,ICE,DCE,NOPTI>, powersave: 1
cpu0: ohare L2 cache enabled
bandit0 at mainbus0
pci0 at bandit0 bus 0
pchb0 at pci0 dev 11 function 0
pchb0: vendor 0x106b product 0x0008 (rev. 0x02)
ex0 at pci0 dev 13 function 0: 3Com 3c905B-TX 10/100 Ethernet (rev. 0x30)
ex0: interrupting at irq 23
ex0: MAC address 00:50:04:65:51:1a
exphy0 at ex0 phy 24: 3Com internal media interface
exphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
obio0 at pci0 dev 16 function 0: addr 0xf3000000
mesh0 at obio0 offset 0x10000 irq 12: 50MHz, SCSI ID 7
scsibus0 at mesh0: 8 targets, 8 luns per target
mesh0: couldn't establish power handler
zsc0 at obio0 irq 15,16
zstty0 at zsc0 channel 0 (console i/o)
zstty1 at zsc0 channel 1
awacs at obio0 offset 0x14000 not configured
swim3 at obio0 offset 0x15000 not configured
nvram0 at obio0 offset 0x60000
cuda0 at obio0 offset 0x16000 irq 18
nadb0 at cuda0: Apple Desktop Bus
iic at cuda0 not configured
wdc0 at obio0 offset 0x20000 irq property not found; using 13: DMA transfer
atabus0 at wdc0 channel 0
vmmask 7e000000 schedmask 7e000000 highmask 7e000000
scsibus0: waiting 2 seconds for devices to settle...
adbkbd0 at nadb0 addr 2: extended keyboard
wskbd0 at adbkbd0 mux 1
nadb0: ADB relative pointing device not configured
cd0 at scsibus0 target 3 lun 0: <MATSHITA, CD-ROM CR-506, 8S05> cdrom removable
wd0 at atabus0 drive 0
wd0: <ST320011A>
wd0: 19092 MB, 38792 cyl, 16 head, 63 sec, 512 bytes/sect x 39102336 sectors
boot device: cd0
root on md0a dumps on md0b
root file system type: ffs
erase ^H, werase ^W, kill ^U, intr ^C, status ^T
Terminal type? [vt100] 
Erase is backspace.
(I)nstall, (S)hell or (H)alt ? s

The first time I tried I got a "can't map interrupt" error
on ex(4) attach, but it worked after cleanup.

Izumi Tsutsui

Home | Main Index | Thread Index | Old Index