Port-macppc archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Where's boot?


Every time that I try to create one of the partitions, I receive this message: The map is not big enough.

My HD belongs to 10Gb and him uses Apple Partition Map. I tried to create a partition HFS 100mb, using the same procedure described in the link below.

Only that even so, I don't get to create the partition, but if I use just (2p) for "First block" and (2p) for "Length in blocks", the partition is created, but it is not how it should be. I don't understand very well of this part, then I don't know what happens.

I don't understand the "(2p)" part. Have you tried to set the sizes explicitly as numbers of sectors?

But in agreement with what it was said in the link above, I made everything certain. Will it be that if I eliminate Apple Partition Map, the problem it is solved?

Hmmm... Are you saying that you think the problem might be that the Apple Partition Map is still on the drive? I don't think that getting rid of it will necesarily fix anything, but it might be worth a try.

When doing recent macppc installs, I've been a little lazy and I've just plugged the drives into other Macs and set up partitions there. Then I use pdisk (which comes with OS X) to change the partition types, ftp to fetch ofwboot.xcf, netbsd-INSTALL.gz and netbsd-GENERIC.gz into the HFS partition, then bring that disk to the NetBSD system and boot it.

Disk Utility in 10.6 doesn't let you make partitions smaller than a gigabyte and doesn't let you create HFS filesystems, so 10.5 is better for that.


Home | Main Index | Thread Index | Old Index