Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Beaglebone broken

Hi, Robert, port-arm

I updated source around 15th Oct, and cleaned objdir/destdir and built evbarm,
and tried to boot with my DREAMPLUG.

But I found the result is the same as before.
I also tried netbsd.gz.ub taken from
Uboot detected gzipped image, but it cannot boot, either.

* are these the same with you ?
  - u-boot is loading netbsd.ub at 0x06400000 and jumping at 0x8000.

* do you have any change in config file from SHEEVAPLUG rev. 1.35 ?
  - I have some changes,
    o enabled VERBOSE_INIT_ARM
    o root on sd2 because my root file system is on external USB HDD
    o add pseudo device pf and pflog

Best regards,
Shoichi Miyake

> ## Booting kernel from Legacy Image at 06400000 ...
>   Image Name:   NetBSD/sheevaplug 6.99.24
>   Created:      2013-10-13   6:00:31 UTC
>   Image Type:   ARM NetBSD Kernel Image (uncompressed)
>   Data Size:    5182016 Bytes = 4.9 MiB
>   Load Address: 00008000
>   Entry Point:  00008000
>   Verifying Checksum ... OK
>   Loading Kernel Image ... OK
> OK
> ## Transferring control to NetBSD stage-2 loader (at address 00008000) ...

2013/10/17 Shoichi Miyake <shoichi.miyake%gmail.com@localhost>:
> Hi, Robert
> 2013/10/16 22:36 "Robert Swindells" <rjs%fdy2.co.uk@localhost>:
>> Shoichi Miyake wrote:
>> >My platform is classic arm, built with build.sh -m evbarm, and I'm not
>> >familiar with
>> >earm platform yet, sorry.
>> >(where should I check to learn about earm platform ?)
>> >
>> >And I found differences with your situation by seeing your log,
>> >you actually reach to invoke init, but I cannot see any kernel boot
>> >messages at all.
>> >It seems to be a little different.
>> >I'm going to update source and build new kernel both evbarm and
>> >evbearm this weekend.
>> I built an evbarm kernel for my SheevaPlug on Sunday and it worked fine.
> Thank you for good info, then it likely be just my fault, maybe .
>> Have you tried booting the netbsd.gz.ub image instead of netbsd.ub ?
> No, I haven't. I always use netbsd.ub because kern-SHEEVAPLUG.tgz
> doesn't have it .
> I will try it , thank you for your advise!
> Best regards,
> Shoichi Miyake
>> Robert Swindells

Home | Main Index | Thread Index | Old Index