Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Beaglebone broken


I've been using DREAMPLUG with SHEEVAPLUG config file
of 6.99.19 fine until today.
But I updated to 6.99.24 today, built and tried new netbsd.ub and
failed to boot.

I found your problem on list that is similar to my case,
but you seem to have solved, ..sigh.

Does anybody have the similar problem with SHEEVAPLUG or DREAMPLUG ?

Best regards,
Shoichi Miyake

U-Boot 2011.06 (Oct 15 2011 - 02:02:08)

SoC:   Kirkwood 88F6281_A0
DRAM:  512 MiB
SF: Detected MX25L1606 with page size 256, total 1 MiB
In:    serial
Out:   serial
Err:   serial
Net:   egiga0, egiga1
88E1121 Initialized on egiga0
88E1121 Initialized on egiga1
Hit any key to stop autoboot:  0
iniializing usb bus
(Re)start USB...
USB:   Register 10011 NbrPorts 1
scanning bus for devices... 7 USB Device(s) found
       scanning bus for storage devices... Device NOT ready
   Request Sense returned 00 00 00
3 Storage Device(s) found
try sdcard-ext
loading nb kernel
reading netbsd.ub

5182080 bytes read
## Booting kernel from Legacy Image at 06400000 ...
   Image Name:   NetBSD/sheevaplug 6.99.24
   Created:      2013-10-13   6:00:31 UTC
   Image Type:   ARM NetBSD Kernel Image (uncompressed)
   Data Size:    5182016 Bytes = 4.9 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
   Loading Kernel Image ... OK
## Transferring control to NetBSD stage-2 loader (at address 00008000) ...

2013/10/8 John Klos <john%ziaspace.com@localhost>:
> Hi,
>>> I tried updating my Beaglebone and saw that not only do we have hardware
>>> floating point (yay!) but that we also have a Beaglebone disk image.
>>> However, while the bootloader works, the kernel never launches:
>> For what it's worth I just copied a kernel from a -current build done
>> about 18 hours ago onto mine and it booted just fine (the board was
>> running a September 2 kernel prior to that).  Whatever the problem is,
>> it isn't a general problem.
> I think the problem is me :) The names Beaglebone and Beagleboard are so
> similar that I didn't notice that the image I was using was called
> beagleboard.img.gz. Although I still don't know how
> netbsd-BEAGLEBONE_INSTALL.gz or netbsd-BEAGLEBONE_INSTALL.bin.gz are
> supposed to be used because neither is in .ub format (both give "Wrong Image
> Format for bootm command"), I was able to boot netbsd-BEAGLEBONE.ub.gz after
> ungzipping to the PC-DOS partition, then giving ld0a for the root on boot.
> The Beagleboard image with the Beaglebone kernel seems to work OK.
> Thanks,
> John

Home | Main Index | Thread Index | Old Index