Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: TS7200_INSTALL kernel problem solved - kernel too big!

>I have been lurking here hoping that you blokes would be able to find
>a fix for this problem but things seem to have gone quiet again. I can
>run 3.1.1 fine on my TS-7200 but 4.0.1 is failing with the same error
>previously discussed here, i.e. dropping to the debugger. I have also
>tried CURRENT but am getting the same problem. I am more a user than
>an operating system hacker so I really wish you good luck with fixing
>this problem as I am very keen to see NetBSD supported on the TS-7200

I'm sorry, dude, I thought I explained it clearly.

Right now really the only solution is to trim some of the fat off
of the TS-7200 kernel.  The TS-7200 has only 32MB of memory in a
few different chunks, and I don't think there are more than 8MB
contiguous (Jesse, if you're still listening ... the memory map in
the TS-7200 documentation seems to be missing this, and I think
it's wrong about the lowest chunk).  In theory I think it would be
possible to rejigger things so a larger kernel could fit ... but
that runs into problems with fitting it in flash (right now not only
does the INSTALL kernel not fit into memory, the non-INSTALL gzipped
kernel doesn't fit into the spot available in flash).

So, if you feel up to it, you can relatively painlessly cross-compile
a TS7200 and TS7200_INSTALL kernel with a bunch of stuff taken out
of the kernel config file.  There's a bunch of crap in there that
you very likely don't need (like all of those USB ethernet adapters,
for starters).  If you don't feel up to that ... well, I'd be willing
to do that for you.


Home | Main Index | Thread Index | Old Index