Port-arm archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: TS7200_INSTALL kernel problem solved - kernel too big!

I have been lurking here hoping that you blokes would be able to find
a fix for this problem but things seem to have gone quiet again. I can
run 3.1.1 fine on my TS-7200 but 4.0.1 is failing with the same error
previously discussed here, i.e. dropping to the debugger. I have also
tried CURRENT but am getting the same problem. I am more a user than
an operating system hacker so I really wish you good luck with fixing
this problem as I am very keen to see NetBSD supported on the TS-7200


Patrick Collins

On 09/12/2008, Ken Hornstein <kenh%cmf.nrl.navy.mil@localhost> wrote:
> >>Please test the changes I just made to evbarm/tsarm/tsarm_start.S
> >>It will now (in theory) map the entire kernel :)
> >
> >Hm ... forgive my stupidity, but it looks like you just changed the mapping
> >so it would calculate it based on the end size of the kernel image.  But
> >I didn't think the TS-7200 actually _had_ any SDRAM past the first 8MB chunk.
> >But anyway, I'll give that a try later on today.
> So, I finally got a chance to try those patches you put into tsarm_start.S.
> Unfortunately, no go ... it dropped to a gdb-remote stub after a few seconds
> (previously it failed almost instantly).
> So ... should those changes be reverted?
> --Ken

Patrick Collins
+61 419 712 581

Home | Main Index | Thread Index | Old Index