Port-acorn32 archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD4 INSTALL kernel fails to boot on A7000

Peter Howkins wrote:
On Wed, Oct 8, 2008 at 10:19 AM, Chris Gilbert <chris%dokein.co.uk@localhost> 
Peter Howkins wrote:

 I'm attempting to boot the INSTALL kernel from


and get the following

<snip kernel error>

I wonder (as the kernel is 3.8MB) if when booted it passes a 4MB limit.

Could you try the latest bootloader?  I did some work on it recently,
and it might have fixed this issue.  Note that a 4.x kernel should work
with it.


I tried this btNetBSD with the above install kernel, and it failed in
the same way.

However I tried the InstKern inside the !btNetBSD archive and it worked [1]
My previous attempts with the InstKern from the 3.1 and 4.0 !btNetBSD
both failed.
They'd load, then instead of dropping to a NetBSD screen, would reboot the box.

That's what I expected (I probably wasn't clear enough that you only needed to grab the bootloader, not the kernel.)

[1] Well booted, I started stepping through the install steps and got a error
on the disc formatting stage (newfs), but I might be able to work past that,
but regardless I'll get another photo of it for you.

Yeah more details would be useful.


ps. I like that the new install kernel in the daily dir runs at
640x480 @ 60 Hz. the previous
install and running kernels ran at 85Hz making finding a suitable
monitor much more difficult, and ruled out most LCD panels.

I think we actually keep the display as it was in RISC-OS, IE we don't change what was working prior to RISC-OS. At some point we might be more intelligent, eg try and read DDC info and make a mode from that but for now we rely on what was set in RISC-OS


Home | Main Index | Thread Index | Old Index