pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Can't build xsetroot from HEAD

On Tue, 5 Feb 2013, Paul Newhouse wrote:

> checking for XSETROOT... configure: error: Package requirements (xmuu x11 
> xbitmaps xcursor xproto >= 7.0.17) were not met:
> Requested 'xproto >= 7.0.17' but version of Xproto is 7.0.15

pkgsrc/x11/xsetroot/Makefile probably needs:

BUILDLINK_API_DEPENDS.xproto+=          xproto>=7.0.17

Please try that.

An alternative is to patch the configure to not be strict and see if it 
works correctly. But my advice is to just use what the upstream 

Home | Main Index | Thread Index | Old Index