pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Can't build xsetroot from HEAD

# uname -a
NetBSD mail 5.0.2 NetBSD 5.0.2 (MAIL) #5: Tue Apr 26 17:38:29 PDT 2011  
root@mail:/usr/src/BUILD_OBJ/sys/arch/i386/compile/MAIL i386

# (cd x11/xsetroot && make  distclean clean update) # replace & install also 
checking if cc -std=gnu99 supports -Werror... yes
checking if cc -std=gnu99 supports -Werror=attributes... no
Package xorg-macros was not found in the pkg-config search path.
Perhaps you should add the directory containing `xorg-macros.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xorg-macros' found
checking for XSETROOT... configure: error: Package requirements (xmuu x11 
xbitmaps xcursor xproto >= 7.0.17) were not met:

Requested 'xproto >= 7.0.17' but version of Xproto is 7.0.15

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XSETROOT_CFLAGS
and XSETROOT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

make: stopped in /usr/pkgsrc/x11/xsetroot
*** Error code 1

make: stopped in /usr/pkgsrc/x11/xsetroot
# pwd
# pkg_info|grep macro
m4-1.4.16nb3        GNU version of UNIX m4 macro language processor
xorg-util-macros-1.17 Xorg autotool macros
tex-epsf-2.7.4      Simple macros for EPS inclusion

# ls CVS
Entries     Repository  Root

Where did I go wrong??


Home | Main Index | Thread Index | Old Index