pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pari requiring fltk???? (proposing to stop)

On 5 November 2012 08:52, Ian McWilliam <> wrote:
> On 5/11/2012 10:39 AM, Greg Troxel wrote:
>> math/pari requires fltk by default, via the x11 option.
>> So while each step might be ok, the notion that fltk is required to
>> install perl modules is ridiculous.  (It's further semi-ridiculous that
>> it needs tex to build, but at least that's build only.)  So I propose to
>> apply the following.  (I ran into this trying to build wip/fldigi which
>> uses fltk13.)  Objections?
> Please do, I have to build pari without x11 support as fltk won't build on
> Mac OS X as a newer fltk is needed to get around certain Mac library
> changes.
> I myself don't use pari, it is a build dependency for other things I use.


Actually it might be nice to add a pari-x11 package which just depends
on pari and then installs a single gp-x11 or similar executable with
x11 enabled (for those binary package using users)

... but that doesn't affect my agreement on removing x11 by default right now :)

Home | Main Index | Thread Index | Old Index