pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Strange firefox behaviour

On Thu 25 Oct 2012 at 18:52:13 +0200, Wladimir Sidorenko wrote:
> I have set NoAccel to True a couple of hours ago and haven't noticed
> any artefacts in firefox since then.

It seems I need to amend my findings. In my first try I just had

        Option     "NoAccel"

and I tried again with

        Option     "NoAccel" "yes"

I thought those would be equivalent[1], but apparently not. Or I did
something wrong.
This time, Firefox didn't seem affected any more. GVim was still
affected (it may well be a separate problem).

I also copied /usr/X11R7/bin/Xorg over, and its associated modules
directory, and started this with the command

        startx -- /usr/X11R7/bin/Xorg5.1 -config xorg.conf.5.1

where xorg.conf.5.1 contained (among the normal configuration) the
module path for the 5.1 module files.

This also helped Firefox, but not GVim (!).
I verified that GVim still worked fine on my other machine (which is
fully 5.1 + the same latest pkgsrc). So that is a bit weird.

Xorg.0.log contained among other things:

X.Org X Server 1.6.3
Release Date: 2009-7-7
(II) intel(0): Integrated Graphics Chipset: Intel(R) Mobile Intel® GM45 Express
(--) intel(0): Chipset: "Mobile Intel® GM45 Express Chipset"
(==) intel(0): Using EXA for acceleration

[1] xorg.conf(5) claims that. Quote:

       Example: the following option entries are equivalent:

           Option "Accel"   "Off"
           Option "NoAccel"
           Option "NoAccel" "On"
           Option "Accel"   "false"
           Option "Accel"   "no"

___ Olaf 'Rhialto' Seibert  -- There's no point being grown-up if you 
\X/ rhialto/at/    -- can't be childish sometimes. -The 4th Doctor

Home | Main Index | Thread Index | Old Index