pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: swig update to 1.3.40

2012/7/1 Takahiro Kambe <>

In message <>
        on Sun, 01 Jul 2012 10:54:24 -0400,
        Greg Troxel <> wrote:
> I have an update for swig to 1.3.40 (from 1.3.36) ready to go.  This has
> not been touched in years.  1.3.37 had a regression, fixed in .38, and I
> had asked people to be careful updating due to gnuradio.
I've also tested 1.3.40, 1.3.37 and 1.3.38.

As for x11/ruby-wxruby, 1.3.38 is happy with both ruby18 and ruby193.
But 1.3.40 had some problem AFAIR.  So, I agree to update to 1.3.38
but not 1.3.40.

Anyway, what about GNU radio?

Quote from devel/swig/Makefile:

# 1.3.37 has a bug where .py files are written to the directory of the
# .i file instead of where the output is supposed to go, and this
# breaks gnuradio.  Please try to contact before
# updating to 1.3.37.  See message on discuss-gnuradio:
# Message-Id: <>
# x11/ruby-wxruby-2.0.1 requires 1.3.32 for Ruby 1.8 and 1.3.37 for
# Ruby 1.9.  And SWIG 1.3.39 introduced some incompatibility with
# wxRuby, sigh.

> At this point I think it's time to update, and sort out whatever needs
> sorting, so my plan is to commit an update to 1.3.40 (which was just
> version and PLIST changes) soon, and then at some point to update to
> 2.0.x, which may be harder.
I have devel/swig2 package localy.  What softwae would need swig 2.x?

wip/ufc require swig > 2.0


Best regards.

Takahiro Kambe <>

Home | Main Index | Thread Index | Old Index