pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Still require --enable-wide-getaddrinfo for ruby?

Am 04.06.2011 14:50, schrieb OBATA Akio:


On Linux and Solaris, both ruby18-base and ruby19-base,
CONFIGURE_ARGS+=    --enable-wide-getaddrinfo

At least with my SSD/Linux 0.4, it result in linkage error because
source codes enabled with the option are using deprecated functions.

I believe that default configure options are preferred in these days
(also on Solaris?),  so it should be gone away.
Does anyone still require it? (old Solaris, or Linux with old glibc?)

At least on my installation (Solaris 10/x86), this switch seriously impacted name resolution and I had to disable it anyway. One of the updates to a recent ruby brought this up. Unfortunately, I can't remember which one it exactly was.

Best regards,

Stephan Tesch                Phone + 49 (0)7071-9457-608
science + computing ag       FAX   + 49 (0)7071-9457-511
Hagellocher Weg 73
D-72070 Tuebingen            Email:

Vorstand/Board of Management:
Dr. Bernd Finkbeiner, Dr. Roland Niemeier, Dr. Arno Steitz, Dr. Ingrid Zech
Vorsitzender des Aufsichtsrats/
Chairman of the Supervisory Board:
Philippe Miltin
Sitz/Registered Office: Tuebingen
Registergericht/Registration Court: Stuttgart
Registernummer/Commercial Register No.: HRB 382196

Home | Main Index | Thread Index | Old Index