pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Still require --enable-wide-getaddrinfo for ruby?

On 6.6.2011, at 8:47, Stephan Tesch wrote:

> Am 04.06.2011 14:50, schrieb OBATA Akio:
> Hi,
>> On Linux and Solaris, both ruby18-base and ruby19-base,
>> CONFIGURE_ARGS+=    --enable-wide-getaddrinfo
>> At least with my SSD/Linux 0.4, it result in linkage error because
>> source codes enabled with the option are using deprecated functions.
>> I believe that default configure options are preferred in these days
>> (also on Solaris?),  so it should be gone away.
>> Does anyone still require it? (old Solaris, or Linux with old glibc?)
> At least on my installation (Solaris 10/x86), this switch seriously impacted 
> name resolution and I had to disable it anyway. One of the updates to a 
> recent ruby brought this up. Unfortunately, I can't remember which one it 
> exactly was.

Ditto. On our systems (snv_89 and newer), this option pretty much prevents Ruby 
from resolving properly at all, so it makes no sense to me. I don't know the 
history though (where older OS versions may be concerned).


Home | Main Index | Thread Index | Old Index