pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Error "Unresolvable dependencies found" with pbulk

On Mon, Apr 18, 2011 at 12:16:13AM +0200, Joerg Sonnenberger wrote:
> On Sun, Apr 17, 2011 at 03:25:05PM -0300, Silas Silva wrote:
> > I included wip/py-buildbot in my list of packages to build with pbulk.
> > But pbulk exists with an error in the scan/resolve phase:
> > 
> >     Unresolvable dependencies found, exiting:
> >     databases/py-sqlite3
> Most likely candidate is that it tries to use Python 2.4, but the
> dependency doesn't support that (since it restricts the use to Python
> 2.5 and later).

Hmmmm, you are right.  Including "PYTHON_VERSIONS_ACCEPTED=25 26 27"
seemed to solve the problem (at least at the scan/resolve phase), I'm
not waiting to get it fully packaged (many dependencies) to send this
feedback :-)

Cc'ing haad@ if he want to fix that in CVS, although I also have commit
access to the wip CVS repository.

BTW, the lack of the "PYTHON_VERSIONS_ACCEPTED" set in the Makefile
doesn't prevent a normal build, only a build from pbulk, that has
scan/resolve phases.  Is there a list of "problems" => "probable
solutions" somewhere (a troubleshooting page)?  Does it exist already?


Silas Silva

Home | Main Index | Thread Index | Old Index