pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

mail/claws-mail-pgp does not work


I'm using NetBSD-current (5.99.48) and a -current pkgsrc from two days ago. I
have problems when using claws-mail to encrypt or sign messages, i.e. every
gpg-operation that requires user-input, verifying signatures works.

Whenever I want to encrypt a message, claws hangs, as it starts
gpg2/gpg-agent to get the passphrase, but they try to get the password from a
console - thus, no input is possible.

Claws-mail should be using gpgme as is configured, but when tracing it, I see
it calling gpg-agent (which is disabled by my user-configuration) and then
failing if I kill gpg-agent. The same setup (I took over the
configuration) worked on my Linux-box.
I tried recompiling all packages that deal with it, but no change.

Is it only my setup that's wrong or do others have the same problem and I
should look deeper in it?

Btw: My psi-gpg-plugin also does not work (can't select keys), which also
depends on gpgme. Is it related?

Regards, Julian

Home | Main Index | Thread Index | Old Index