pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: HEADS UP: Options of "apache22" package changed

Summary of offlist discussion:

  The rest of the world configures apache with the modules being shared
  objects (that must be explicitly loaded).

  When a security problem is found in a module, configs not loading it
  are not aaffected, and people can disable it if they don't need it,
  making reacting to the security issue easier.

  The apache-shared-modules default change indeed causes problems where
  many previously valid apache config files no longer work.  But, the
  above reasons outweigh the (one-time) problems.

Also, the new


has LoadModule lines; if you merge all of them into your previous
httpd.conf, then apache will work and be in essentially the same state
as before.  But now you can trim things you don't want.

Attachment: pgpNYCdqghCNF.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index