pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: HEADS UP: Options of "apache22" package changed

  1.) The option "apache-shared-modules" is now enabled by default.
      Ths means that all Apache modules will be built as ".so" files.
      If you haven't used ths option in the past you need to either
      disable it or add the missing "LoadModule" directives to the
      Apache configuration.

      You can find a list of the modules and their documentation here:

What's the rationale for changing the default?  I updated via pkg_rr and
restarted apache and it failed to start; I load mod_dav_svn and
mod_authz_svn explicitly and they now require mod_dav and some other
things.  I can see the point of not loading things you don't want, but
it would seem that the new default breaks many users.  I don't know how
my config could have been wrong - there's no way to specify loading
mod_dav from a file that doesn't exist.

Did I miss discussion of this change?

If there's no compelling reason to change the default, I'd like to see
this reverted.  (I know I can change it in my mk.conf.  My point is that
updating packages and restarting the system should be a fairly safe

Attachment: pgpT5w4PlwS15.pgp
Description: PGP signature

Home | Main Index | Thread Index | Old Index