pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Ruby 1.8.7p249 and Ruby 1.9

In message <>
        on Mon, 22 Mar 2010 15:38:38 -0700,
        Michael Graff <> wrote:
> It would be lovely to have packages for thee.  1.8.7p249 has a problem
> on NetBSD with the pthreads code, and appears to have some other
Yes, 1.8.7p249 has critical problem with pthread code and it was the
reason why I didn't update but add patches to fix security problem.

> problems as well as I could not get the tests to pass.  However, the
> tests for the current version in pkgsrc also fail...
Note, NetBSD isn't officially supported platform by Ruby.

So, don't expect to pass all tests of Ruby althogh some Ruby's
developpers work on problems on NetBSD...

> Note that Ruby on Rails 3.0 will require Ruby 1.9.
That's a bad news (at least for me).

Anyway, I'm (very) slowly working on Ruby 1.9 support.

Takahiro Kambe <>

Home | Main Index | Thread Index | Old Index