pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

mbone/beacon caveat (PERL5_PACKLIST)


I'm looking into updating mbone/beacon, since I don't find the current (old) version in pkgsrc useful. To fix 1.3 (which we also have running and working) was easy to get it done, with one caveat.

PERL5_PACKLIST=         auto/Net/Multicast/Beacon/.packlist

Is interpreted as in the "vendor_perl" directory branch, and installation ends with an error:

Perl packlist /usr/pkgsrc/mbone/beacon/work/.destdir/usr/pkg/lib/perl5/ vendor_perl/5.10.0/i386-netbsd-thread-multi/auto/Net/Multicast/ Beacon/.packlist is missing.
*** Error code 1

make: stopped in /usr/pkgsrc/mbone/beacon
*** Error code 1

make: stopped in /usr/pkgsrc/mbone/beacon

The .packlist file is on the filesystem, but all the perl related package stuff is installed in the "site_perl" directory tree instead:

/usr/pkgsrc/mbone/beacon/work/.destdir/usr/pkg/lib/perl5/site_perl/ 5.10.0/i386-netbsd-thread-multi/auto/Net/Multicast/Beacon/.packlist

So my question is if this can be fixed with some Makefile foo?
I mean, either install the package to vendor_perl directory tree, or make PERL5_PACKFILE look in site_perl directory tree instead.
(Whatever make the perl mongers happy...)


Home | Main Index | Thread Index | Old Index