pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Does firefox 3.5 on netbsd-4/i386 work?

Hi Tobias,

On Sat, Nov 21, 2009 at 03:23:46PM +0100, Tobias Nygren wrote:

> On Sat, 21 Nov 2009 23:58:13 +1100
> Simon Burge <> wrote:
> > I've just upgraded my netbsd-4/i386 machine to pkgsrc-2008Q3, which
> > included a jump from firefox- to firefox-3.5.3nb2.
> > 
> > When I try to start firefox, xulrunner pops up a dialog box or three
> > which disappear to quickly to see what they say.  If I start with no
> > ~/.mozilla directory I get three of these dialog boxes, and if I start
> > with an existing profile I get just one of these.  Then xulrunner-bin
> > dumps core.
> This sounds vaguely familiar. I think it can happen when fontconfig
> doesn't find any fonts.

I've tried things like:

        rm -rf ~/.font*

with no noticeable change in behaviour.

> > Note that if I start /usr/pkg/lib/firefox/firefox directly, instead of
> > using the /usr/pkg/bin/firefox script it does appear to start (after
> > popping up two dialog boxes that disappear like earlier) but then after
> > the initial firefox window starts it appears to wedge and the firefox
> > process has two threads, one blocked in sawait and the other in poll.
> The stub launcher is known to not work correctly. You really need
> to start it like done in the wrapper script (but see below...).
> > First question - has anyone successfully used firefox 3.5 on netbsd-4?
> Haven't used XFree86 in a long time, sorry.

Does xorg work on netbsd-4?  I could try that, but it'll probably be a
couple of weekends away.  This is my main workstation, and I'm trying
not to make it too unavailable.  I guess a next step is upgrading to
netbsd-5, but I've been putting that off for as long as possible :-)

> > Second question - any suggestions on making this work?
> If you rebuild xulrunner with PKG_OPTIONS.xulrunner+=debug in mk.conf
> it should print some clues to the problem on stderr. There were some
> additional debugging instructions posted earlier:

I've attached two log files.  The first was with no pre-existing
~/.mozilla directory.  After this, the xulrunner back trace is:

   #0  0xb997622f in kill () from /usr/lib/
   #1  0xb9a12340 in abort () from /usr/lib/
   #2  0xb99d4c06 in __assert13 () from /usr/lib/
   #3  0xb9b4c207 in _cairo_hash_table_destroy () from 
   #4  0xb9b5c383 in _cairo_scaled_font_map_destroy () from 
   #5  0xb9b482b2 in _cairo_font_face_reset_static_data () from 
   #6  0xb9b48063 in cairo_debug_reset_static_data () from 
   #7  0xba4d3703 in gtk_moz_embed_get_title () from 
   #8  0xba4dc1f3 in XRE_main () from /usr/pkg/lib/xulrunner/
   #9  0x0804a9e8 in _rtld_setup ()
   #10 0x08049d84 in ___start ()
   #11 0x08049ce7 in _start ()

When I run firefox a second time, the log file is reasonably different and the
back trace is quite different:

   #0  0xb963a10b in FcPatternObjectPosition () from 
   #1  0xb963a169 in FcPatternObjectFindElt () from 
   #2  0xb963b284 in IA__FcPatternRemove () from /usr/pkg/lib/
   #3  0xbb6e10f6 in gfxPangoFontGroup::GetFcFamilies () from 
   #4  0xbb6e28a8 in gfxPangoFontGroup::NewFontEntry () from 
   #5  0xbb6e73c0 in gfxPangoFontGroup::MakeFontSet () from 
   #6  0xbb6e9183 in gfxPangoFontGroup::GetBaseFontSet () from 
   #7  0xbb6e9d7d in gfxPangoFontGroup::GetBasePangoFont () from 
   #8  0xbb6ea8a9 in gfxPangoFontGroup::GetFontAt () from 
   #9  0xbb4f16a5 in non-virtual thunk to nsPrintSession::Release() () from 
   #10 0x089e1280 in ?? ()
   #11 0x00000000 in ?? ()

I've also tried (suggested in the thread you pointed me too) running:

        /usr/pkg/lib/xulrunner/xulrunner-bin \
            /usr/pkg/lib/firefox/application.ini -safe-mode -jsconsole

but that gives the same backtrace as the previous back trace.

Does the existance of cairo and pango in these traces point to general
X/fontish related problems?  The only other "gui" type programs I really
use are amarok and digikam, and both of these appear to be working fine.


Attachment: firefox-a.out.bz2
Description: Binary data

Attachment: firefox-b.out.bz2
Description: Binary data

Home | Main Index | Thread Index | Old Index