pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lang/mzscheme is not only for the platforms specified in Makefile

On Thu, May 21, 2009 at 01:23:00PM +0400, Alexey Lebedev wrote:
> So, maybe the line
> ONLY_FOR_PLATFORM+=   Linux-*-x86_64
> just should be added to Makefile?

I just committed that.

> I tried to run Paul Graham's Arc using mzscheme compiled this way and
> it worked fine.
> More than this. I got mzscheme compiled even under amd64 NetBSD but I
> had to replace the libffi library included in mzscheme tarball with
> the one from devel/libffi but it took me to do some hacks.
> Maybe I'll try to make things up and create a patch so that mzscheme
> would be available under amd64 NetBSD as well but Linux's version is
> working right now.

Sounds like the package should depend on devel/libffi -- could you
perhaps generate patches for that?


Home | Main Index | Thread Index | Old Index