pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

ap2-fcgid not working


I am trying to run ap2-fcgid on apache2 and apache22 but it is not
successful at all.
I am using one of the latest NetBSD 5.0 beta.

I configured apache using the documentation on
and getting this error in /var/log/httpd/err_log
[emerg] (2)No such file or directory: mod_fcgid: Can't create share
memory for size %zu byte

I can see apache consuming semaphores using the command ipcs. After some
apache restarts the semaphores are becoming full and I need to ipcrm
them (or reboot).

Googling about that problem did not help so far. I tried to increase
shared memory, semaphores, changed the way semaphores are used etc. In
particular I changerd the option SSL_Mutex in ssl.conf from
file:/var/run/ssl_mutex to sem (as a proposed solution found in Google)
but with no effect.

I tried the same before on DragonFlyBSD 2.0.1 with no luch either.

Is anybody using fcgid successfully?

I'd appreciate any help.


Home | Main Index | Thread Index | Old Index