[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: Version requirements for dependancies
On Tue, Nov 11, 2008 at 10:03:49AM -0600, Jeremy C. Reed wrote:
> I don't know why databases/db4/buildlink3.mk has
> BUILDLINK_API_DEPENDS.db4+= db4>=188.8.131.52
> Maybe it should be reverted.
> It would be especially nice if any definition of BUILDLINK_API_DEPENDS (or
> BUILDLINK_ABI_DEPENDS) also has a comment explaining why it was last
> changed. Maybe we should have that as a policy.
It was last bumped because the name of the shared library changed.
Together with a PKGREVISION bump of all dependencies, this makes sure
that a consistent binary package set will exist. I.e. every foo-1.0
created from pkgsrc default settings will depend on db4-4.6, while
every foo-1.0nb1 will depend on db4-4.7.
If we didn't do this, you could build a binary package for foo-1.0
from pkgsrc and it would depend on the time of the build if it was
linked against db4-4.6 or 4.7; but you can have only one or the other
installed, so you start having trouble as soon as two or more packages
want different versions of the same library.
With the API and PKGREVISION bumps, we make sure that a consistent
binary package consists which will definitely depend on the newer
version and can be installed at the same time.
Main Index |
Thread Index |