pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

RE: Version requirements for dependancies

On Tuesday, November 11, 2008 3:07 AM, Robert Elz <> scribbled:
> You're absolutely right, the dependency system in pkgsrc is about as
> broken as it is possible to be, while still kind of working (though at
> a cost to all of the users).  
> [...]

All very well said, and I find myself in complete agreement.  I've
recognized this before, but never stated it so well.  I also realize that it
is certainly a non-trivial task to fix it.  But I believe it must be done.
I'm willing to put in the work to update the packages I maintain.  I
generally try to include exact dependency version information already.

Tim Larson        AMT2 Unix Systems Administrator
    InterCall, a division of West Corporation

               Eschew obfuscation!

Attachment: smime.p7s
Description: S/MIME cryptographic signature

Home | Main Index | Thread Index | Old Index