pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: forced upgrade to perl-5.10.0?

On Sat, 8 Nov 2008, Klaus Heinz wrote:

> is it really intended that I have to update perl to version 5.10 if I
> just want to install a perl module on a system with a perfectly working 
> 5.8.8? 
> If the module were depending on perl-5.10 I would understand this, but
> in fact it does not. So why am I forced to update perl?

It would be nice if this was not required (such as USE_ABI_DEPENDS=NO for 
daring experts).

But if the forced update is not done, then there may be a mix of 
mismatched "perl" packages when using other's packages and your own 
(because of hardcoded and maybe required "5.10" locations).

As for the experts who never use others' packages, maybe there should be 
away to disregard this update.(??)

Home | Main Index | Thread Index | Old Index