pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Subversion server no longer accessible after upgrading to NetBSD 4.0.1

On Wed, Nov 5, 2008 at 8:22 PM, Dan Engholm
<> wrote:
> Adrian Maier wrote:
>> On Tue, Nov 4, 2008 at 3:57 PM, Manuel Bouyer 
>> <>
>> wrote:
>>> On Tue, Nov 04, 2008 at 07:46:15PM +0200, Adrian Maier wrote:
>>>    Does 'netstat -a -f inet' list the svn port as listening ?
>> No,  the svn port does not appear in the list of listening ports.
>> I have upgraded the svn to 1.4.2.  Nothing changed.  I have also
>> tried to run the svnserve with the options:
>> svnserve -r /data/svn -X --foreground --listen-port=9009
>> but it is not giving any kind of hint about what could be wrong. The bad
>> thing
>> is that svnserve doesn't seem to create any kind of log file. And
>> it also doesn't have command line options for increasing the
>> verbosity.
> Adrian,
> I normally run svnserve from inetd and have not had any trouble running it
> on either of my two 4.0.1 boxes on which I run svnserve.  I just tried using
> svnserve as its own daemon and was surprised to see that it does exactly as
> you said.  netstat -afinet does not show the svn port in use.  Even netstat
> -anfinet does net see it but lsof -i :svn does.  Even so, I was able to use
> svn to do a directory listing through the server and since I had specified
> -X, the server exited as soon as the ls command completed.
> This is definitely a weird one.  It's like there's now an implicit stealth
> socket option.  The machine on which I experimented does not even have
> ipfilter enabled, so that shouldn't be a contributing factor.

I've found the solution and I'm posting it here so that it remains in
the archive
in case someone else encounters the same situation.

Luckily I have found a hint in this article :
Apparently the problem is something like "when IPv6 is enabled
svnserve is not accessible
through IPv4 addresses unless you add  --listen-host ".
IPv6 probably got
enabled on my machine because of the upgrade to 4.0.1 ...

So,  everything works normally  if I run svn serve with :
/usr/pkg/bin/svnserve -d -r /data/svn --listen-host

Thanks for your tips,  Manuel and Dan  !

Adrian Maier

Home | Main Index | Thread Index | Old Index