pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Subversion server no longer accessible after upgrading to NetBSD 4.0.1

On Tue, Nov 4, 2008 at 3:57 PM, Manuel Bouyer 
<> wrote:
> On Tue, Nov 04, 2008 at 07:46:15PM +0200, Adrian Maier wrote:
>> Hello,
>> Before the upgrade, my server used to run NetBSD 3.0 . One of the
>> services running
>> on this machine is the subversion server (v.1.3.0)  ) is called from
>> rc.local with:
>> su username  -c "/usr/pkg/bin/svnserve -d -r  /data/svn_repo "
>> So,  i was able to connect to the svn repository with urls like "
>> svn://" .
>> Yesterday I have upgraded the machine to NetBSD 4.0.1 .   The pkgsrc
>> packages are
>> still the old ones ( the plan is to upgrade all of them, too,  when I
>> find the time to take
>> care of this ).
>> The current problem is that now I am getting :
>> svn: Can't connect to host '': Connection refused
>> whenever I try to access the svn repository using the "svn://"  protocol .
>> The svnserve process is launched at boot  and seems to be operational
>> (it is listed
>> in the ps  , and  when I run it manually it doesn't generate any
>> errors).   Yet,
>> it is not accessible.
> Does 'netstat -a -f inet' list the svn port as listening ?

No,  the svn port does not appear in the list of listening ports.

I have upgraded the svn to 1.4.2.  Nothing changed.  I have also
tried to run the svnserve with the options:
svnserve -r /data/svn -X --foreground --listen-port=9009

but it is not giving any kind of hint about what could be wrong. The bad thing
is that svnserve doesn't seem to create any kind of log file. And
it also doesn't have command line options for increasing the
verbosity .

Best wishes,
Adrian M.

Home | Main Index | Thread Index | Old Index