pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

can't install graphics/gimp after x11/kdebase3

On a NetBSD/amd64 4.0 machine I've unpacked into /usr/pkgsrc, then ran 'make' and 'make install' from within /usr/pkgsrc/x11/kdebase3, which seemed to go OK. However, when I ran 'make' from /usr/pkgsrc/graphics/gimp it failed with:

checking for GLIB... configure: error: Package requirements (           glib-2.
0 >= 2.12.0              gthread-2.0 >= 2.12.0) were not met:

No package 'glib-2.0' found
No package 'gthread-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

make: stopped in /usr/pkgsrc/graphics/librsvg
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package Mak
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/librsvg
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/gimp

According to the output of 'make fetch-list' in x11/kdebase3 it requires glib-2.18.0 so what's the recommended method of getting around this apparent clash, please?

I haven't tried, but perhaps x11/kdebase3 would have installed happily if I'd put glib-2.12.0.tar.bz2 in /usr/pkgsrc/distfiles instead of glib-2.18.0.tar.bz2, and then graphics/gimp would have installed OK too?


Home | Main Index | Thread Index | Old Index