pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Jumping cursor in modular-xorg-server- (was: modular-xorg and DRM/DRI checkpoint)

On Wednesday 02 July 2008, you wrote:
> On Wednesday 02 July 2008, Jared D. McNeill wrote:
> > On Wed, 2 Jul 2008, Joel CARNAT wrote:
> > > So what's best testing ?
> > > - pkgsrc-2008Q1 + graphics/MesaLib and graphics/Mesa from -HEAD
> > > - pkgsrc-HEAD + x11/modular-xorg-server 2.1.1
> >
> > Third option is pkgsrc-HEAD + pkgsrc-wip for modular-xorg 1.4.0
> >
> > I'm using 1.4.0+latest intel driver on one machine and 1.3.0+intel 2.1.1
> > on another. Both are functional, Xorg 1.4.0 is much nicer :-)
> With modular-xorg-server- on i386 current,  I'm having problems
> with the mouse cursor jumping to the left edge of the screen (the y
> position is correct but x=0).  It looks like the culprit is the xorg server
> itself, as the problem goes away if I change the mouse driver to send
> absolute x,y positions instead of deltas (openbsd-input-ws-1.2nb1 has "if
> 0"ed code to do this).  The problem is more pronounced when mousing across
> complex Web pages.

I've tracked the jumping cursor issue down to the function acceleratePointer 
in dix/getevents.c.  Occasionally, it modifies delta x from, e.g., -17 
to -2147483648.  I have "solved" the problem by saving the delta x value 
before the call to acceleratePointer (also in getevents.c) and using the 
saved value when the new value is unresonable.  There is, I'm sure, a better 
way.  I looked through the commit log for getevents.c and several changes 
appear relevant.  For some reason it does not affect the y position.


Home | Main Index | Thread Index | Old Index