NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD 9.1 amd64, base X11: garbled display

On Sat, Apr 10, 2021 at 01:53:48PM -0500, John D. Baker wrote:
> As this is a USB-stick installation, I presume you expect to be able to
> boot it on any machine you encounter?  Other systems with intel graphics
> devices may be just fine with SNA, so you may want to move the "xorg.conf"
> aside on those systems.  Of course, you won't know for sure until you
> try it each way.

I have tried this USB stick installation on 1 more laptop where it worked
fine with default xorg configuration. But it's a different chipset.

On this other m/c, on Linux:

# lspci -vvv -s 0:1.0
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI]
Stoney [Radeon R2/R3/R4/R5 Graphics] (rev ea) (prog-if 00 [VGA
        Subsystem: Lenovo Stoney [Radeon R2/R3/R4/R5 Graphics]
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 34
        Region 0: Memory at e8000000 (64-bit, prefetchable) [size=128M]
        Region 2: Memory at f0800000 (64-bit, prefetchable) [size=8M]
        Region 4: I/O ports at 4000 [size=256]
        Region 5: Memory at f0400000 (32-bit, non-prefetchable)
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [48] Vendor Specific Information: Len=08 <?>
        Capabilities: [50] Power Management version 3
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [58] Express (v2) Root Complex Integrated Endpoint,
MSI 00
                DevCap: MaxPayload 256 bytes, PhantFunc 0
                        ExtTag+ RBE+ FLReset-
                DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
                        RlxdOrd+ ExtTag+ PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 256 bytes, MaxReadReq 512 bytes
                DevSta: CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr-
                DevCap2: Completion Timeout: Not Supported, TimeoutDis-,
                         10BitTagComp-, 10BitTagReq-, OBFF Not Supported,
ExtFmt+, EETLPPrefix+, MaxEETLPPrefixes 1
                         EmergencyPowerReduction Not Supported,
                         AtomicOpsCap: 32bit- 64bit- 128bitCAS-
                DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-,
LTR-, OBFF Disabled
                         AtomicOpsCtl: ReqEn-
        Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
                Address: 00000000fee01004  Data: 4026
        Capabilities: [100 v1] Vendor Specific Information: ID=0001 Rev=1
Len=010 <?>
        Capabilities: [270 v1] Secondary PCI Express
                LnkCtl3: LnkEquIntrruptEn-, PerformEqu-
                LaneErrStat: 0
        Capabilities: [2b0 v1] Address Translation Service (ATS)
                ATSCap: Invalidate Queue Depth: 00
                ATSCtl: Enable-, Smallest Translation Unit: 00
        Capabilities: [2c0 v1] Page Request Interface (PRI)
                PRICtl: Enable- Reset-
                PRISta: RF- UPRGI- Stopped+
                Page Request Capacity: 00000020, Page Request Allocation:
        Capabilities: [2d0 v1] Process Address Space ID (PASID)
                PASIDCap: Exec- Priv-, Max PASID Width: 10
                PASIDCtl: Enable- Exec- Priv-
        Kernel driver in use: amdgpu
        Kernel modules: amdgpu

I have 1 more machine, which is not with me right now. Can try it some
other day if it is going to help get any idea.


Home | Main Index | Thread Index | Old Index