NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation troubles on UEFI/GPT laptop (possible bug?)

Hi james,

Are toi try to update gribouille ans boot netbsd in to grue ?
How tou boot on micro$oft ?

How tou boot on Windows an Linux for switch between ?
I suggest édit grue for boot for all tour système...

UEFI havé juste 100Mo for big Kernel is small, may be nerf to upper it... i imagine netbsd is the kernel to enough.

Best regard & tale café.

> Le 30 sept. 2020 à 23:48, James Browning <> a écrit :
> Hi all,
> I am attempting to install NetBSD 9.0 on my UEFI enabled laptop's GPT disk. This disk also contains 
> windows and linux paritions, so I do not want to clear the partition table. I attempted installation 
> using a usb drive with the install image 'NetBSD-9.0-amd64-uefi-install.img'. The laptop model is 
> Acer Aspire E15 E5-575G-57D4. 
> I have attempted many methods to correctly format the partition, but nothing seems to be working,
> and I am not sure if this is the result of bugs or user ignorance. From my perspective the problem
> appears to be Sysinst not cooperating with my GPT.
> My steps to attempt this installation are:
> 1. In linux, use gparted to create a new partiton which will contain NetBSD, I figured the file system 
>   type I select is arbitrary because Sysinst will format the partition to FFS
> 2. The resulting partition table looks like :
>    Disk /dev/sda: 238.49 GiB, 256060514304 bytes, 500118192 sectors
>    Disk model: Micron_1100_MTFD
>    Units: sectors of 1 * 512 = 512 bytes
>    Sector size (logical/physical): 512 bytes / 512 bytes
>    I/O size (minimum/optimal): 512 bytes / 512 bytes
>    Disklabel type: gpt
>    Disk identifier: C3E0E834-7CB3-463F-B8B2-3075FC41D216
>    Device         Start       End   Sectors  Size Type
>    /dev/sda1       2048    206847    204800  100M EFI System
>    /dev/sda2     206848    239615     32768   16M Microsoft reserved
>    /dev/sda3     239616 289686755 289447140  138G Microsoft basic data
>    /dev/sda4  498020352 500117503   2097152    1G Windows recovery environment
>    /dev/sda5  330246144 498020351 167774208   80G Linux filesystem
>    /dev/sda6  289687552 330246143  40558592 19.3G Linux filesystem
>    Partition table entries are not in disk order.
> The 19.3G /dev/sda6 partition is the target partion for NetBSD 
> 3. I then shutdown and boot into Sysinst and take the following steps:
>   Select "a: Install NetBSD on hard disk"
>   Select "b: yes"
>   I then select the partition I reserved for NetBSD
>   Sysinst asks if I wish to continue, I select "b: yes"
>   Systisnt asks "The selected partition does not seem to have a valid file system. Do you want to newfs it?"
>   I select "b: yes"
>   I then get the following error:  "Status: Command Failed, Command: /sbin/newfs -V2 -O2 /dev//rdk5/, 
>                                     newfs: /dev//rdk5/ partition type is not '4.2BSD'"
>   Followed by the error: "Status: Command Failed, Command: /sbin/mount -o async /dev/dk5 /targetroot/
>                           mount_ext2fs: /dev/dk5 on /targetroot: Read-only file system"
>   Sysinst then returns the main menu
> 4. After that I tried to use to the utility menu to format the partition like so:
>   I select "e: utility menu" -> "d: partiton a disk"
>   I select the target partition which at this point is still listed as Ext2 file system
>   I select "a: edit" then I change type to "FFSv2" and I change mount, install, and newfs all to "yes"
>   I change the label to "4.2BSD"
>   When I select "Save Changes" the following error occurs: 
>        "Status: Command failed
>         Command: gpt label -b 289687552 -T 49f48d5a-b10e-11dc-b99b-0019d1879648 wd0"
> 5. After that I repeat the steps I listed in section 3, but instead of producing any error, I simply
>   get kicked back to the main menu with no messages, but NetBSD is not installed in the partition.
>   However when I return to linux the parition fs type has been changed to ufs.
> Any ideas on what is going on here? I really have no idea if it is me or Sysinst that is in the wrong here.
> I have also tried manually formatting the partition using the Sysinst shell and trying out the gpt and disklabel
> commands, but they always return errors such as "device busy" or "ioctl misuse" (this is a paraphrase, I can't 
> recall the exact error). I am certain I'm using the commands on the correct device as I always ensure it matches
> the device listed in the partition utility.
> Thank you for taking the time to read this and potentially help me,
> James Browning

Home | Main Index | Thread Index | Old Index