NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

boot issues

I am in the process of replacing a failed disk drive on a server.
It is an i386 machine, and has been running 7.0.1 for the past 18
months or so.   It took a massive hammering from .ru and .cn addresses
a couple of weeks back which finally did for the disk drive (which
deserved a long-service medal anyway and was intended to be replace).

It lost /usr and /var, which were on separate partitions, but the
rest was preserved and passed fsck checks when I got it back here and
ran it single user.

So I have copied over everything but /var and /usr onto a new, shiny,
bigger disk, and re-installed all the /usr and /var files from the
7.0.1 distribution .iso, selectively from the .tgz sets using
tar xvhpkfC.   Before I install the disk in the server box (a 1U rack
unit) I want to check that I'm not going to have to take it out again,
because it's physically fiddly and tightly packed.  So I've put it in
an old system I have here where it is configured as wd2, and I try
booting it with boot hd2a:netbsd -a.

I get two issues: the first is an error report that cannot
be found (but it's there in /dev/wd2a); the second is that it reports
that getty is repeating too quickly on /dev/console.  It proceeds to
displaying the date and time banner, but does not produce a login
prompt.   I have tried changing /etc/ttys in ways relating to stuff on
the web reporting similar errors but to no avail.  The /etc/ttys I
have on the new disk was dimply copied over from the old disk, but I
tried changing to match what is on the old machine.   I have vague
memories of seeing a similar problem around 15 years ago, but I have
no real grasp of what the issue may be.

Steve Blinkhorn <>

Home | Main Index | Thread Index | Old Index