NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Old thinkpad and X11, 6.1.2 update


di did a complete, fresh install of 6.1.2 on a new HD.

Guess what? it still doesn't work. I configured the machien to have a static IP and I tried also with a different, wired, ethernet PCMCIA card.

I can even do the following, most of the time it works

1) start with card plugged in, computer boots, network configured, start X, black screen, it hangs... pull out the PCMCIA card, it will recover and display a working X

2) start without card, no network, start X, it starts at the first attempt... put in the network card, it will freeze!!! Most often, removing the card, unfreezes.

As already written, I tried several cards and without X, the computer is rock-stable for days.


Riccardo Mottola wrote:

if no one has a clue, I'll proceed with a new install of 6.1.2. Given that the machine is fine but not very speedy, I tried to avoid that.

I can just add (given some suggestions I got in the past weeks)

1) The hardware should be OK, the driver works: without network X displays without errors
2) The network card works well without X and works in other computers
3) The machine itself (e.g. memory) is stable: without X it was able co compile packages from pkgsrc for 3 days non-stop!


On 10/18/13 01:13, Riccardo Mottola wrote:

I still have the esxtremely strange problem that when network is configured, I X11 makes a black screen! I updated to 6.1.2 (I was running 6.1) but no help.

The network is, if ocnfigured, now staticall configured (to exclude X11)

Ifconfig shows:
        inet netmask 0xffffff00 broadcast

Both the hostname and the localhost lookfine:
narsil$ ping -c 1 narsil
PING narsil.westernesse.arda ( 52 data bytes
64 bytes from icmp_seq=0 ttl=255 time=0.312 ms

narsil$ ping -c 1 localhost
PING localhost ( 52 data bytes
64 bytes from icmp_seq=0 ttl=255 time=0.310 ms

Being really clueless, I though of archiving the Xorg log when run without network (=works) and with networks (hangs with black screen).
Do you see anything suspicious? Wrong?


Home | Main Index | Thread Index | Old Index