NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wpi0: fatal firmware error

Thank you for your answer.

On 11/06/2013 02:46, Pierre Pronchery wrote:
>                       Hi,
> On 05/11/2013 23:11, Béla wrote:
>> Hello fellow NetBSD users,
>> I have dabbled with NetBSD in VirtualBox for some time now and today I
>> decided to install NetBSD-amd64 version 6.1.2 on my Thinkpad T61 laptop.
>> The T61 comes with the Intel(R) PRO/Wireless 3945ABG wireless card - or
>> wpi, NetBSD seems to have the appropriate driver for it, and necessary
>> firmware is also made available(I used the wpi-firmware2-2.14.4 binary
>> package from pkgsrc). But, whenever I bring the interface up(ifconfig
>> wpi0 up), I get this error:
>> wpi0: fatal firmware error
>> I also tried the old firmware wpi-firmware-1.13, with no more success; I
>> get the same error.
>> Any ideas how to make this wireless card work?
>> Does anybody run NetBSD with this wifi card?
> I have a T60 running netbsd-6, and the 3945abg wifi card works fine
> there. Haven't tried it for a while, can try again though.

So you are running the i386 port? Is it possible my problem occurs in
the amd64 port only?

> Kind of a silly question, but are you sure you have enabled the radio
> switch? (but it should not fail this way except if it really can't load
> the firmware...)

Yes the switch is on. I have also tried switching on and off twice like
the man page notes for wpi suggest but this yields nothing. If the
switch is off, bringing the interface up outputs "wpi0: radio is
disabled by hardware switch", which is correct behaviour, so I guess
some things do work...

> Are the firmware files really installed where they are expected to be?
> The path is either "/usr/pkg/libdata/firmware/if_wpi" or
> "/usr/pkg/libdata/if_wpi", the latter being where the package
> effectively installs the files. See also the output of "sysctl
> hw.firmware.path" to confirm.

sysctl hw.firmware.path outputs: hw.firmware.path =

the iwlwifi-3945.ucode firmware file is in /usr/pkg/libdata/if_wpi

>> BTW, I have not configured dhcpd/dhclient or wpa_supplicant yet; I see
>> no reason to, first I need to get the firmware working.
> HTH,

Is there a way I can get more information than just "wpi0: fatal
firmware error"?

Also, I noticed something odd, when I remove the firmware, I still get
"wpi0: fatal firmware error" instead of "wpi0: could not read firmware
file" or "wpi0: could not load firmware" as the manuel suggest error
messagges should be...

Home | Main Index | Thread Index | Old Index