NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wpi0: fatal firmware error


On 5 November 2013 22:11, Béla <> wrote:
> Hello fellow NetBSD users,
> I have dabbled with NetBSD in VirtualBox for some time now and today I
> decided to install NetBSD-amd64 version 6.1.2 on my Thinkpad T61 laptop.
> The T61 comes with the Intel(R) PRO/Wireless 3945ABG wireless card - or
> wpi, NetBSD seems to have the appropriate driver for it, and necessary
> firmware is also made available(I used the wpi-firmware2-2.14.4 binary
> package from pkgsrc). But, whenever I bring the interface up(ifconfig
> wpi0 up), I get this error:
> wpi0: fatal firmware error
> I also tried the old firmware wpi-firmware-1.13, with no more success; I
> get the same error.

I used to have a T61p (now, sadly, the NVidia graphics card saw the
best of it). I've never done anything to download firmware to this one
- it just works out of the box (i.e. after clean -current installation
from CD, configuring wpa_supplicant and enabling dhcpcd). The wireless
card in it is identical to yours.  It has been extremely reliable
(well, I've never lost connection to my home router and to some may be
10 others I've connected it). Obviously I haven't tried 6.1.2 (when
that was out, the laptop was already dead).

> Any ideas how to make this wireless card work?
> Does anybody run NetBSD with this wifi card?
> BTW, I have not configured dhcpd/dhclient or wpa_supplicant yet; I see
> no reason to, first I need to get the firmware working.

I've never tried to manually configure the card (or any other
wireless, for that matter). I just configure wpa_supplicant and dhcpcd
(earlier dhclient) and it just works. Although I run -current usually.



Home | Main Index | Thread Index | Old Index