NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: upgrading pkgsrc on current problems with xextproto


anybody has a tip on that? I updated pkgsrc today, still the same trouble

Emacs wants gtk3. Gtk dails to llink without libXi, libXi fails with:

checking for XEXT... configure: error: Package requirements (xproto >= 7.0.13 x11 >= xextproto >= 7.1.99) were not met:

Requested 'xextproto >= 7.1.99' but version of XExtProto is 7.1.2

but the newest xextproto is 7.2.1 .

What am I missing?

Riccardo Mottola wrote:

(I don't know if this is more appropriate to users or current mailing list).

on current, I updated pkgsrc to current too and started upgrading issuing "make update" in the packages identified by lintpkgsrc -i.

While updating emacs, the update aborted on gdk3, giving link errors to undefined references of funtions of libxi (shouldn't the upgrade automatically pull in that dependency?)

I thus tried to install manually x11/libXi, but it stopped because xextproto was too old, I updated it but it did nto help. I installed 7.2.1 of xextproto, but libXi requires 7.1.99

What now? at the current stage updating emacs also unistalled firefox and thunderbird, my system is quite.... barebones now :)


Home | Main Index | Thread Index | Old Index