NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: tw_cli reports not configured

On Mon, 11 Mar 2013, Matthias Scheler wrote:
On Thu, Jan 10, 2013 at 04:06:46PM +0000, Stephen Borrill wrote:
I've been using the FreeBSD binary tw_cli for a number of years. This
machine is running 5.1_STABLE from July-ish.  I'm sure when I was running
an earlier netbsd-5 version it worked fine.

backup 1# tw_cli rescan

(0x08:0x0006): (0x08:0x0006): Device not configured

Segmentation fault (core dumped)

ktrace shows a number of these:
11741      1 tw_cli   CALL  open(0xbfbfd540,2,0xbfbfd948)
11741      1 tw_cli   NAMI  "/emul/freebsd/dev/twe0"
11741      1 tw_cli   NAMI  "/dev/twe0"
11741      1 tw_cli   RET   open -1 errno 6 Device not configured

Is the major number of /dev/twe0 97?

Thanks :-)

backup 1# ls -l /dev/twe0
crw-------  1 root  wheel  146, 0 Jan 10 10:46 /dev/twe0
backup 2# rm /dev/twe0
backup 3# cd /dev
backup 4# sh MAKEDEV twe0
backup 5# ls -l /dev/twe0
crw-------  1 root  wheel  97, 0 Jan 10 16:05 /dev/twe0
backup 6# tw_cli rescan
Rescanning controller /c0 for units and drives ...Done.
Found the following unit(s): [none].
Found the following drive(s): [none].

Does the command now actually work for you? Because it doesn't for me
under NetBSD/i386 6.0_STABLE even with the correct major number:

tron@beaver:/dev#ls -l twe0
crw-------  1 root  wheel  97, 0 Mar 11 18:34 twe0
tron@beaver:/dev#tw_cli info c0 u1
Error: (CLI:006) Specified unit does not exist.

This command worked fine under NetBSD 5.0 and 5.1.

Sorry, I don't have a machine with a twe(4) that I can put NetBSD 6 on (they are in production at other sites).


Home | Main Index | Thread Index | Old Index