NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: NetBSD 6 upgrade removes pty files, causing issues with inferior processes in emacs

On Tue, Nov 13, 2012 at 11:09:38AM +0100, Martin Husemann wrote:
> On Tue, Nov 13, 2012 at 10:59:26AM +0100, Peter Bex wrote:
> > I guess it needs to attempt to open /dev/pts/N (being the "correct"
> > way to do this I asked about)?  That, it doesn't do according to a
> > ktrace.
> I would expect it to use openpty(3) and friends - which emacs version
> are you using exactly? Is it from pkgsrc?

It's emacs 24.2nb2, installed using pkgin from$arch/6.0/All
(arch being amd64)

I've also built it from pkgsrc manually on my other machine, it's
the same version I think.  In any case, I built it a couple days ago,
with a fresh checkout of pkgsrc-current so it's fairly recent.

"The process of preparing programs for a digital computer
 is especially attractive, not only because it can be economically
 and scientifically rewarding, but also because it can be an aesthetic
 experience much like composing poetry or music."
                                                        -- Donald Knuth

Home | Main Index | Thread Index | Old Index