NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: usb stick install

On 9/25/12 2:55 AM, Ib-Michael Martinsen wrote:
Thor Lancelot Simon writes:
 > On Sat, Sep 22, 2012 at 10:03:38AM +0200, Ib-Michael Martinsen wrote:
 > >
 > > The USB stick was populated with
 > >
 > > # dd if=NetBSD-6.0_RC1-i386.iso of=/dev/sd0d bs=4k
 > This isn't really the right way to dd the data -- use the raw, not
 > the block device -- but if the result with other USB sticks is
 > something you can boot from, then yes, I'd be inclined to blame
 > the BIOS or the stick itself (though it's a little hard to see
 > how).

I have also tried

# dd if=NetBSD-6.0_RC1-i386.iso of=/dev/rsd0d bs=4k

it made no difference, i.e. it is still impossible to boot from the
USB-stick. So it seems I will have to use my 2GB and 8GB devices as
boot devices. I can live with that.

you should try:
# dd if=NetBSD-6.0_RC1-i386.iso of=/dev/sd0 bs=4k

the letter after the number in sd0d is a partition/slice. in my case i
did dd to the identifier itself in - this case sd0 - and it worked. but
not the iso. that was always bypassed. the install img booted. but than
it failed with stuff like:

hd0a:[netbsd.gz|onetbsd.gz|netbsd.old.gz] No such file or directory.

it's just been a really not very pleasant experience to try installing
netbsd off a stick. nobody seems to know really what's going on with
this img install. the instructions on line say you'd have to gunzip the
image and dd it unzipped to the stick but then at boot the thing is
looking for all those gz files...

anyway... i'll try cd next. except i don't have a drive on my laptop
anymore. it's just doesn't come with one.
i would have stuck to freebsd except the xen support in netbsd 6.0 looks
really attractive...

Kind regards

Home | Main Index | Thread Index | Old Index