NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: git insists in using IPv6

   Date: Fri, 17 Aug 2012 16:24:09 -0400
   From: Julio Merino <>

   I'm not sure if something changed in NetBSD to cause this, but I
   cannot longer "git clone" from some hosts because it insists on using
   IPv6 addresses and I don't have IPv6 support.  For example:

   $ git clone
   Cloning into 'kyua'...   
   error: Failed to connect to 2607:f8b0:4004:801::1007: No route to host
   while accessing
   fatal: HTTP request failed

A little ktracing reveals that git, presumably while somewhere in
libcurl, successfully connects via IPv4 to, exchanges
some TLS messages, and then closes the connection before subsequently
connecting via IPv6 and failing.

What I suspect happened is that the certificate verification failed
via IPv4, so curl tried connecting via the next address it got from
getaddrinfo, and in the end reported only the last failure it saw,
namely the IPv6 error rather than the certificate verification error.
That is, Git doesn't insist on using IPv6; curl just chooses, of the
errors it has available to report, the one about IPv6.

Setting GIT_SSL_NO_VERIFY=1 in my environment makes the `git clone'
work; I expect that pointing http.sslCAInfo or GIT_SSL_CAINFO at the
relevant root CA certificates would also make it work.

How it worked before, though, I don't know...  Perhaps Google only
recently started serving a AAAA record for

Home | Main Index | Thread Index | Old Index