NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: asterisk: module load warnings

On Mon, 9 Apr 2012 00:25:59 +0530 Mayuresh wrote:
> On Sun, Apr 08, 2012 at 11:01:17AM -0700, John Nemeth wrote:
> > On Aug 29,  4:18pm, Mayuresh wrote:
> > }
> > } Tried this with comm/asterisk18 as well as comm/asterisk10.
> > } 
> >      What is missing here is all the details of your setup, i.e. the
> > exact version of Asterisk, the version of NetBSD, what platform, etc.
> Two versions of asterisk are mentioned above. This was on NetBSD 6.0 BETA
> on i386 - if that matters. The conf file was default - well no
> configuration had yet started. I felt those errors mean something wrong
> with installation itself. So not turned to configuring as yet.

I ran into a similar problem with asterisk16. I created a NetBSD/i386 6.0_BETA2 
system from the 6.0_BETA2 iso, with all packages installed using pkgin from the 
pkgsrc 6.0_BETA2 archive.

Something goes wrong in asterisk's main/loader.c when loading modules, shortly 
after the call to dlopen(). Sometimes asterisk will actually segfault shortly 
thereafter (see below), or it will print either the "Module 'xxx' does not 
provide a description." or "Module 'xxx' could not be loaded." message.

This is with asterisk-

Program received signal SIGSEGV, Segmentation fault
[Switching to LWP 1]
0xbb7bf7b0 in strlen () from /usr/lib/
(gdb) bt
#0  0xbb7bf7b0 in strlen () from /usr/lib/
#1  0x080cfd2f in verify_key (key=0x89000000 <Address 0x89000000 out of bounds>)
    at loader.c:298
#2  0x080d0c6c in inspect_module (mod=<optimized out>) at loader.c:719
#3  load_resource (resource_name=0xbab2d050 "", 
    resource_heap=0xbab179c0) at loader.c:809
#4  0x080d0f49 in load_resource_list (load_order=0xbfbfd7a4, global_symbols=0, 
    mod_count=0xbfbfd7ac) at loader.c:900
#5  0x080d12c4 in load_modules (preload_only=0) at loader.c:1068
#6  0x080750c9 in main (argc=<optimized out>, argv=Cannot access memory at 
address 0xb0818e03) at asterisk.c:3758

The segfault occurs mostly when loading or which are 
by far the biggest modules.


Home | Main Index | Thread Index | Old Index