NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Problems with vnd on an external USB-hdd

Hello list.

I tried mounting a disk image that resided on an external USB-hdd
the other day. This is what happened:
# mount -t ffs /dev/vnd0a /mnt
mount_ffs: /dev/vnd0a on /mnt: incorrect super block
I also saw that when running vnconfig the kernel spits out:
vnd0: dos partition I/O error

When checking the disklabel I get this:
Which is weird since the disk image is miniroot.fs for hpcarm.
Copying the file to the normal internal HDD makes it work.

Even curiouser is that copying the image to a USB flash drive makes
it work also... It worked for the people on #netbsd@freenode that
tried it, but all of them tried it on flash drives too.

Flash drive:
scsibus2 at umass2: 2 targets, 1 lun per target
sd2 at scsibus2 target 0 lun 0: <SanDisk, Cruzer, 8.01> disk removable
sd2: 3829 MB, 61280 cyl, 4 head, 32 sec, 512 bytes/sect x 7843839 sectors

External HDD:
sd0 at scsibus0 target 0 lun 0: <WD, My Book 1130, 1012> disk fixed
sd0: fabricating a geometry
sd0: 2794 GB, 357694 cyl, 64 head, 32 sec, 4096 bytes/sect x 732558336 sectors

The HDD is a 4k/sector drive, could that be it?

This is on i386 and a few days old -current (5.99.58)

This drive is over 2TB but can still use disklabels since it is a
4k/sector drive. Maybe that should be clarified in the bugs section
in the man page for disklabel(8)?

CC me for reply.

Home | Main Index | Thread Index | Old Index