NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: wip/libreoffice or misc/openoffice?

On 30 Nov 2011 at 9:44, Mayuresh wrote:

> On Tue, Nov 29, 2011 at 03:03:39PM -0500, wrote:
> >    I tried building both misc/openoffice and wip/libreoffice recently on
> > amd64/current, and both failed to build. I didn't look into the details
> > at the time, but took the easy way out and loaded wip/libreoffice3-bin.
> > Someone with a higher pain threshold might want to take a look...
> I built OO yesterday. Only issue I faced was the downloaded distfiles were
> corrupt. They had initial html text followed by binary tarball. Bad...

I've had a few of those corrupt downloads, some being 
exact size of wanted distfile and others being web pages.
Either way it's a build failure and I'll then try master 
site or

I'm currently building in a diy chroot for each quarter 
release (started with 2010Q4). I then update my pcs from
the created binary packages, so far using 'pkg_chk -b -u'
but I might try pkgin or nih. So far I've not had more 
than a few minutes service downtime whilst updating.

I don't have any desktop with recent NetBSD as each update
has even more broken packages than the previous. Most recent
is NetBSD-5.0 and as a desktop it is still usable and feels
to be more responsive than my Ubuntu desktop.


> I downloaded all tarballs again from master site. Then it built fine.
> wip/libreoffice is not building for me.
> As of now I am not too tempted to try binary. Will give OO a try as of now.
> Whenever lo works, will try that out.
> I installed extensions also. pdf import looks interesting. Will give it a
> try.
> Mayuresh.

Home | Main Index | Thread Index | Old Index