NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Fwd: Re: Alpine help, please

Hello, everyone, just wanted to let everyone know the outcome of my Alpine problem with a big Gmail IMAP mailbox (segfaults after a while). Maybe this will help someone else. Thanks again to Jean-Yves for the help.

On Wed, 09 Nov 2011 11:30:55 +0200, Rares Aioanei wrote:
 On 11/09/2011 01:16 AM, Jean-Yves Migeon wrote:
 On 08.11.2011 14:49, Rares Aioanei wrote:
 On 11/08/2011 02:56 PM, Jean-Yves Migeon wrote:
 On Tue, 08 Nov 2011 14:13:53 +0200, Rares Aioanei wrote:
 On 11/08/2011 03:03 AM, Jean-Yves Migeon wrote:
 On 07.11.2011 00:11, Rares Aioanei wrote:
 Hi list,

 I compiled Alpine (pkgsrc-2011Q3) for my 5-STABLE system and it
 OK, but when I tried to open my inbox on a rather large IMAP
 account, it segfaults. On Free and OpenBSD Alpine works with
 the same
 account with no problems. I tried compiling using pthreads but
 outcome is the same: it stays a while on "Sorting messages"
 segfaults leaving a .core file in ~ . Running GDB shows
 from nanosleep(), telling me that it's indeed a threads
 else having the same issue or should I file a bug?

 Thank you in advance.

 Hmmm I am not quite sure that nanosleep is the culprit here. Any
 idea how much memory does it try to eat?

 Right before the crash, I ran top and it showed ~450 MB.

 Does it look the same on other OS where it does not crash? You may
 a ulimit that prevents further allocations. The output of ulimit
 for your session would be interesting too.

 ulimit -a:

 data 262144
 stack 2048
 lockedmem 672500
 nofiles(descriptors) 128
 processes 160
 resident-set 2017500
 , the rest being set to unlimited. The machine has 2GB RAM, if that
 matters, and lots of swap/disk space. The OpenBSD machine is a
 T22 with 256 MB RAM, and on it alpine eats less, around 170 MB, as
 by top.

 Nothing unusual there, except maybe the stack size (you can raise it
 with ulimit -s though).

 Is it possible to get a backtrace from gdb please, without thread
 support compile in?

 Just as I thought! Setting the stack size to 4096 did the trick.
 Thanks, Jean-Yves.

You're welcome

Could you please send a message on the ML? You probably are not in this
situation. NetBSD has a rather small stack size by default, and some
applications choke on it (especially for PIE with ASLR).

Jean-Yves Migeon

Home | Main Index | Thread Index | Old Index