NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: [SOLVED] No response to XDMCP queries using modular xdm

Matthias Scheler wrote:

> On Sun, Nov 06, 2011 at 07:39:01PM +0000, Brian Morley wrote:
> > 
> > I'm not overly familiar with those commands but that lsof seems to
> > suggest that it is only listening on IPv6 addresses - IPv6 isn't set
> > up on this network.
> That seems indeed to be the problem.
> > Does anyone know why that might be and how to get it listening on IPv4?
> Please try to add "LISTEN" to "Xaccess". 

That didn't work, however, used in conjunction with the -debug 100 option 
suggested by Jeremy gave some useful insight, in that the debug info then 
reported receiving the request but authentication was then failing, as opposed 
to previously when there was no response at all.  It appears that wildcards 
don't work at all there: you need either the specific IP of the interface in 
question or a hostname that resolves to it.  In my case I altered it to "LISTEN 
n1c" and it worked straight away.  I'll re-read the docs tomorrow to see if 
they are actually wrong or I simply misunderstood them and file a PR if 
appropriate: it's getting pretty late here now.

Thanks for the help guys.

Home | Main Index | Thread Index | Old Index