NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

non-update builds and "date.def"

Whenever something significant changes in the source tree to warrant a
clean build of the system from scratch (such as changing where my source
tree is located, changes in libssh/libssl a while back, or the recent
compiler change on several platforms), my non-update build always fails

--- install-editres ---
install ===> external/mit/xorg/bin/editres
--- install-share ---
#   install  /d0/build/current/DEST/macppc/usr/X11R7/lib/X11/config/date.def
/d0/build/current/tools/i386/bin/powerpc--netbsd-install -U -M 
/d0/build/current/DEST/macppc/METALOG -D /d0/build/current/DEST/macppc -h 
sha256 -N /d1/nbsd/current/src/etc -c  -r  -o root  -g wheel  -m 444   date.def 
--- install-bin ---
--- /d0/build/current/DEST/macppc/usr/X11R7/bin/editres ---
#   install  /d0/build/current/DEST/macppc/usr/X11R7/bin/editres
/d0/build/current/tools/i386/bin/powerpc--netbsd-install -U -M 
/d0/build/current/DEST/macppc/METALOG -D /d0/build/current/DEST/macppc -h 
sha256 -N /d1/nbsd/current/src/etc -c  -r -o root -g wheel -m 555   editres 
--- /d0/build/current/DEST/macppc/usr/X11R7/man/cat1/editres.0 ---
--- /d0/build/current/DEST/macppc/usr/X11R7/man/html1/editres.html ---
#   install  /d0/build/current/DEST/macppc/usr/X11R7/man/html1/editres.html
/d0/build/current/tools/i386/bin/powerpc--netbsd-install -U -M 
/d0/build/current/DEST/macppc/METALOG -D /d0/build/current/DEST/macppc -h 
sha256 -N /d1/nbsd/current/src/etc -c  -r -o root -g wheel -m 444  
editres.html1 /d0/build/current/DEST/macppc/usr/X11R7/man/html1/editres.html
--- install-share ---
powerpc--netbsd-install: date.def: stat: No such file or directory

(macppc-current shown for example, but happens with i386 and sparc, and
also on netbsd-5 branch)

I suspect this may be the result of a race condition since I typically
build with "-j (ncpu+1)" (or more).  If I start the non-update build
over again, it will fail here every time.  If I restart the build as
an update ("-u") it will complete.  I haven't yet tried omitting "-j".

I keep a template for my build options that typically looks like:

./ -U -m sparc -T /d0/build/netbsd-4/tools/i386 -O 
/d0/build/netbsd-4/obj/sparc -D /d0/build/netbsd-4/DEST/sparc -R 
/d0/build/netbsd-4/REL -X ../xsrc -x -u -j 2 tools release

which I run through 'sed' and use command substitution to change things
like platform or version.  So, the build from which my excerpt was
taken would be started as follows:

  $ cd /path/to/src
  $ $(sed 's,sparc,macppc,g ; s,netbsd-4,current,g ; s,-u ,,' /path/to/template)

I also have not been in the habit of deleteing my build tree except
under the most extreme circumstances so whether update or not it
is populated with the results of the last build (attempt).

Just curious about what causes this very repeatable behavior.

|/"\ John D. Baker, KN5UKS               NetBSD     Darwin/MacOS X
|\ / jdbaker[snail]mylinuxisp[flyspeck]com    OpenBSD            FreeBSD
| X  No HTML/proprietary data in email.   BSD just sits there and works!
|/ \ GPGkeyID:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645

Home | Main Index | Thread Index | Old Index