NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: X11 not starting

On Sun, Jun 19, 2011 at 12:39 PM, Nino on NetBSD 5.0.1 
<> wrote:
> Dear NetBSD users,
> I have a problem that I can only relate over hear-say, as I do not have the 
> actual machine. - A friend of mine has got an ancient Maxdata laptop, model 
> unknown, which should be around 10 years old. WinXP is running on it, 192 MB 
> RAM, 6 GB disk. We tried to replace Windows and installed NetBSD 5.1. It 
> works very well, but we had - and now that is the problem - NO chance to get 
> X11 running.
> Let me mention that this setup has been made from a tar backup that I created 
> from my own system, and it has been already working in numerous environments 
> (including, with some fighting, VirtualBox).
> So, we did Xorg -configure and copied it over to /etc/X11/xorg.conf. When 
> trying to startx, it crashed, giving the message that no screens have been 
> found or that the driver has not enough memory for 1024x1024 (which is 
> strange - the laptop has 1024x768).
> When replacing the driver from "siliconmotion" to "vesa", we get as far as 
> having a little white square cursor on the upper left corner of the screen 
> and then the complete NetBSD system freezes (you can even take out the 
> harddisk, it won't notice; and certainly, Ctrl-Alt-Backspace or even going 
> back with Ctrl-Alt-F2 do NOT work) and needs a hard reset.
> In /etc/X11/xorg.conf, we tried deleting all Depth lines but one, and tried 
> one after the other with depth 16, 15 and 8, we set resolutions manually of 
> 1024x768 and 800x600, we set some horizontal and vertical sync rate (guessed 
> from the net and the FreeBSD guide) - to no avail; either it crashes in a 
> civilized way (with the siliconmotion driver) or it freezes completely (with 
> the vesa driver).
> (On a side note, I have noticed that I was unable to set a fixed resolution 
> on my "real" machine - when I say, I want 640x480, I do NOT get it - X11 
> again starts in 1280x800, so I am not even certain whether setting the 
> resolution in xorg.conf even helps.)
> I must say, I am unfortunately out of ideas. I know well, this is the 
> laptop's fault, not NetBSD's, but I would still be very grateful if you could 
> give me any pointers as to what to try next.
> Thank you in advance for your suggestions and your help!

Maybe there's a better driver in pkgsrc? (x11/xf86-video-siliconmotion)

For your second problem I think you can try xvidtune -next?

Home | Main Index | Thread Index | Old Index