NetBSD-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: postfix smpt auth no worthy mechs found

> On Thu, Jan 27, 2011 at 07:48:58PM -0800, wrote:
>> maps_find: smtp_sasl_passwd:
>> hash:/usr/pkg/etc/postfix/sasl_passwd(0,lock|fold_fix):
>> = <user>:<passwd>
>> followed by no worthy mechs found.
>> So, maybe postfix won't use port 587?
> No, that works fine for me. Please try this in "":
> relayhost = []:587
> And "/usr/pkg/etc/postfix/sasl_passwd" must look like this:
> []:587                <user>:<passwd>
> There must be in particular no equal sign in "sasl_passwd".

Thanks, I have tried various combinations:

in and sasl_passwd.

Contradicting the postfix sasl howto, if I specify the port in and
leave it off in sasl_passwd (with or without square brackets in both), I
no longer get the error message that is not found.

relayhost = []:587

sasl_passwd: <user>:<passwd>

I run postmap hash and restart postfix. Then, (using submission or 587),
it logs:


Trusted TLS connection established to[]:587:
TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)


maps_find: smtp_sasl_passwd:
hash:/usr/pkg/etc/postfix/sasl_passwd(0,lock|fold_fix): =
smtp_sasl_passwd_lookup: host `' user `<user>' pass
starting new SASL client
name_mask: noanonymous
smtp_sasl_authenticate:[]:587: SASL
mechanisms LOGIN PLAIN
warning: SASL authentication failure: No worthy mechs found


send attr reason = SASL authentication failed; cannot authenticate to
server[]: no mechanism available


status=deferred (SASL authentication failed; cannot authenticate to server[]: no mechanism available)


Home | Main Index | Thread Index | Old Index